Quantcast

Is there a way to script the BGM to be not looped (Again)

Hi. I’m reposting a previous topic I made since I couldn’t get a proper answer to it last time. Is there a way to script the BGM for your map to be not looped? I’m trying to make a certain map and this is proven to be a bit of a problem at the end of it. When it’s completed and the music sounds like it’s about to stop, it just loops and starts all over again. Again, any help on this topic would be very much appreciated

with the EventString’s lack of functionalities, i doubt there’s even a way to stop the bgm from looping. sorry!

local bgm = game.Players.LocalPlayer.PlayerScripts.BGM_Folder:FindFirstChild(“BGM”)
if bgm then
    bgm.Playing = false
    wait(0.1)
    bgm.Looped = false
    bgm.Playing = true
end
1 Like

Have you tested this and it 100% works?

i mean that’s billie’s script not mine you just set it’s Looped or Looping or whatever to false

1 Like

Alright, does it go in EventScript or LocalEventScript?

LocalEventScript

1 Like

Doesn’t work. Typical.

guess billie’s script didn’t work

lmao I didnt see this but I already solved it with uncom in dms, if anyone is wondering here is how:

-- Local Script
local BGM = game.Players.LocalPlayer:WaitForChild("PlayerScripts"):WaitForChild("BGM_Folder"):WaitForChild("BGM")
BGM.Looped = false
-- Event Script
for k, v in pairs(game.Players:GetPlayers()) do
    if v.Character and v.Character:FindFirstChild("BGMFalseLoop") == nil then
        local cloned = script.Parent.BGMFalseLoop:Clone()
        cloned.Parent = v.Character
        cloned.Disabled = false
    end
end
1 Like

Kinda wondered why dusk snows bgm looped at 1.59.00 in map test

and also max time of the map is 1:59, not 2:00