Ok can you help me this time with shake?

I have a problem here. I tested it in the StarterPlayer or something idc and it worked. But in FE2 it is like. You shall not pass I named it LocalEventScript didn’t work and now i named it LocalScript

Here’s the actual script itself. (For mistakes blame kris. He scripted it and i copy and pasted it lol)

local RunService = game:GetService(“RunService”)

local Camera = workspace.CurrentCamera

local intensity = 0

local rawIntensity = 4

local lastShake = tick()

local waitTime = 6

local Sound = Instance.new(“Sound”, game.Workspace)

Sound.SoundId = “rbxassetid://5706776276”

Sound.Volume = 1

RunService.RenderStepped:Connect(function(step)

if tick() - lastShake >= waitTime then

intensity = 1

lastShake = tick()

end

Camera.CFrame = Camera.CFrame * CFrame.new(

(math.random() - 0.5) * intensity * rawIntensity,

(math.random() - 0.5) * intensity * rawIntensity,

(math.random() - 0.5) * intensity * rawIntensity

)

intensity = intensity - step

if intensity < 0 then

intensity = 0

end

end)

while wait(waitTime) do

Sound:Play()

end

anyone?

erm, well i did it with a map and it seemed to work for me lol
are you sure no script broke it or anything?

this must be a in a localscript, it should not be disabled and it should be called “LocalEventScript”

it is already but doesnt work in any way i put it

idk maybe but i tested it in the serverscript whatever its called something and it worked but in fe2 its like only normal can pass

lol this works for me, it might ne a cloning issue on ur end

it doesnt work for me though