Why isn't my EventString Working?

local Lib = workspace.Multiplayer.GetMapVals:Invoke() --Has: Map, Script, Button, btnFuncs
Lib.Button:connect(function(p, bNo) if Lib.btnFuncs[bNo] then Lib.btnFuncs[bNo](bNo, p) end end)

Lib.BtnFuncs[2] = function()
Lib.Script.moveWater(Lib.Map.Intro._Door1, Vector3.new(-2.75, 0, 0), 2, true)
Lib.Script.moveWater(Lib.Map.Intro._Door2, Vector3.new(2.75, 0, 0), 2, true)
end

Lib.BtnFuncs[3] = function()
Lib.Script.moveWater(Lib.Map.Intro._Door3, Vector3.new(0, 41, 0), 3, true)
end
Lib.BtnFuncs[11] = function()
Lib.Script.moveWater(Lib.Map.Intro._Door4, Vector3. new(0, 10, 0), 6, true)
end

wait(10)
Lib.Script.moveWater(Lib.Map.Intro._Water1, Vector3.new(0, 0, -100), 14, true)
wait(29)
Lib.Script.moveWater(Lib.Map.Intro._Water9, Vector3.new(0, 27.5, 0), 3, true)
wait(3)
Lib.Script.moveWater(Lib.Map.Intro._Water1, Vector3.new(0, 0, -142), 11, true)
wait(87)
Lib.Script.moveWater(Lib.Map.Intro._Water1, Vector3.new(0, 0, 70), 10, true)

anything wrong?

make sure to copy the eventstring into the eventscript and enable eventscript

wdym?

there’s a random strip of text in the EventString, what you do is copy paste it and paste it into the top of your EventScript

and if the EventScript is disabled, enable it otherwise nothing will work

do you have a intro or did u ungroup

it’s btnFuncs not BtnFuncs (the b is lowercase)

BtnFuncs has its first letter capitalized. Make it lowercase.

enabled script:yes
btnFuncs correct:yes
ptw still not working. do I name the script EventScript?

yes, you do

i did, still not working

send explorer and script one more time

@ LolIsNowExploiting
Screenshot 2020-10-19 110005

use eventscript or eventstring, only one of them

eventscript has eventstring script inside

learn to read

Disable eventscript dude.

its deleted

Oh, also did you put the code inside the eventstring?

yes.
i think it was EventScript that was running, btw the stynax